Imported OBJ (as garment) looks inflated and exports also very different (as OBJ)

  • Rosemary Comment actions Permalink

    Two possible reasons.   

    First, your import scale could be wrong.  Check the size of your avatar.  Since it is in a sitting pose to begin with, the easiest way would be to use Add>Avatar and bring in one of the default MD avatars to do a visual size comparison.  (Normally I would say to use the Measurement tool to check the height of a standing avatar, but the sitting pose will obviously negate that option.)  If your avatar is too small, then the default skin offset will be too large in comparison.  MD works best when the avatars are at real-world human scale, as that is how the cloth properties are programmed.  You may have to adjust the export/import settings to get your avatar and garment to the correct size for MD work.

    Second, click on the avatar's surface, and in the Properties Editor, check the Skin Offset setting.  Default is 3 mm.  If that got changed somehow, that would create the 'balloon' effect, even with a negative pressure setting.  

     

    Lastly, the final image is 'messed up' because there are special rendering settings used by MD when switching to the 'bones' view.  I wouldn't worry about that, because if your normals *had* been flipped, then that negative pressure would have made even more of a balloon effect, and that isn't what is happening. 

  • Alexx Comment actions Permalink

    Many thanks, good tips which I didn't know..

    I will check that out next time :)

    I could solve this (jus for a rough test it was enough today) with a "!turbosmooth" modifier  in 3dsMax.

Please sign in to leave a comment.