Cloth Sim Sizzling at points of contact - How do I fix?

  • Marvelous Designer Team COMMUNITY MANAGER Comment actions Permalink

    It looks like you might be editing the wrong properties. That is the world property editor for animation and physics that I wouldn't recommend making changes to if you can avoid it because you can encounter less than accurate sim/ animation that way, return those settings back to base values and select the avatar AND MESH/ fabric and change their collision thicknesses and particle distance of the materials to stabalize the project. You are likely encountering collission issues with the avatar, and cloth collision thickness/ offset so you can reduce those but rememebr to increase the mesh density to prevent actual collision (you might need to carve out more in the end). Note, make sure your avatar is at human scale which Marvelous Designer requires to work accurately (I can't tell here) but if its not human scale then you are more likely to encounter issues like you are seeing. 

  • geordie Comment actions Permalink

    Okay. will try these approaches and return with results. 

     

  • geordie Comment actions Permalink

    I found the problem. different Layer values are bad when you have pieces from different body parts colliding like this.
    I thought "to keep the pockets inside the jacket I would lower the layer value and they would stay close to the body."
    This was a bad assumption. 
    This forced the points to pop in and out of the sleeve on every other frame causing the sizzling. 
    Here is an image of what was a bad setup:

  • Marvelous Designer Team COMMUNITY MANAGER Comment actions Permalink

    You should be turning off all layer values aka ALL LAYERS= 0  but basically yes, If you are trying to animate with layer values in the scene that often causes simulation issues and collision issues which sounds like you may have found out the hard way. Best practice is to have ALL LAYER VALUES AT 0 at the end of all of your projects especially those with animation, we say this a lot in our tutorials and Live Streams. Hopefully that was the only thing was causing you the issues, let us know if more issues arise. 

  • geordie Comment actions Permalink


    You can just turn of layer based collisions in the sim settings. It's easier that way. It's the bottom-most setting. And you don't have to worry about changing them. 
    It is on by default in the Animation Stable settings. It would be good to have that turned OFF for that solver preset if that is the MD advice for animation solving. 

    I have simmed cloth in a lot of other applications. 
    Artists need to be able to direct collisions better in Marvelous. 

    Layer-based collisions are useless in their current implementation.
    I vote for painting area maps of a particular color on the avatar + cloth so they are paired. 
    Layer-based (layer shock) collisions would then only operate in that color zone and resort to standard collision methods with other colors. 

    This way if the forearm goes through the waist or body the sleeve wouldn't want to slide under the shirt covering the waist and try to collide with the avatar belly, It would prefer just the avatar geometry under the forearm to collide with and ignore other body parts. 

    Also, cloth points caught between two avatar collision parts (i.e. arm and belly pinching the sleeve and shirt bodice) should stop collisions until they have been free of that situation for at least one frame then resume. 

    There are a lot of additional collision operations that can be added to the MD solver that would make it unstoppable.



Please sign in to leave a comment.